Symptoms

When attempting to scan a remote SQL Instance you receive the following error.


Failed to connect to server <servername>. A network-related or instance-specific error occurred while establishing a connection to SQL Server.



Cause

This error can be caused by several configuration or connectivity issues.



Resolution

  • Ensure that the SQL Server instance is running

  • Ensure that the name of the instance is correct - for example "CORP-SRV01" or "CORP-SRV01\SQLExpress"

  • Ensure that the SQL server is enabled for remote connections (see http://support.microsoft.com/kb/914277 for more information).

    • On the SQL Server, open the SQL Server Configuration Manager

    • Select SQL Server Network Configuration

    • Select Protocols for Instance Name

    • Ensure that the required protocols are enabled



  • Ensure that no firewalls are blocking the connection between the machine running the XIA Configuration Client and the SQL server.